PRODEF® Security gloves, Level-5 cut-protection leather, with zipper

€59.90

Prices incl. VAT excl. shipping costs

Immed. available. Delivery time. 1-3 workdays

Größe:

  • 71210
Inconspicuous, lightweight and highly cut resistant - better than any "normal" service glove.... more
PRODEF® Security gloves, Level-5 cut-protection leather, with zipper

Inconspicuous, lightweight and highly cut resistant - better than any "normal" service glove.

The gloves are made of soft quality leather and very well made. From the outside they look like normal service gloves, but the inside is provided with an HPPE cut resistant fibers and thus provide a maximum of cut resistance!

Major Features:
• Inconspicuous and lightweight
• Maximum of cut resistance

Technical specifications:
• Material: soft quality leather
• Colour: black
• Size: M, L, XL, XXL

What are HPPE cut resistant fibers?
HPPE is compared with conventional aramid fibers (which are also used for the manufacture of protective clothing) 40 times higher tensile strength. With respect to carbon fiber or glass fiber tensile strength 60 times and 15 times more tensile strength than steel. Due to its UV stability, low ductility and high cut resistance it offers ideal conditions for processing in protective articles. Therefore, it is used among others in the manufacture of helmets, shields / clothing and armor.


Level-5, what is that?

To determine the cut resistance of a fabric, a razor blade is used to cut into the material. The more pressure can be applied to the razor blade without damaging the fabric, the higher the cut resistance: a small cut resistance has a level of 1, the highest possible level is 5.

Related links to "PRODEF® Security gloves, Level-5 cut-protection leather, with zipper"
Read, write and discuss reviews... more
Customer evaluation for "PRODEF® Security gloves, Level-5 cut-protection leather, with zipper"
Write an evaluation
Evaluations will be activated after verification.
Please enter these characters in the following text field.

The fields marked with * are required.

Certified security